Apache Ant 1.9.16 和 1.10.11 发布,自动化构建工具

2021年07月21日 12:39 15 次阅读 来源: 素文宅 作者: 路人甲
摘要 Apache Ant 1.9.16 和 1.10.11 现在可以作为源代码或二进制文件从https:ant.apache.orgbindownload.cgi下载 。Apache Ant 团队目前维护着两条开发线。1.9.x 版本在运行时需要 Java5,1.10.x 在运行时需要 Java8。这两行都基于 Ant 1.9.7,1.9.x 版本主要是错误修复版本,同时为 1.10.x 开发了其他新...

Apache Ant 1.9.16 和 1.10.11 现在可以作为源代码或二进制文件从https://ant.apache.org/bindownload.cgi下载 。

Apache Ant 团队目前维护着两条开发线。1.9.x 版本在运行时需要 Java5,1.10.x 在运行时需要 Java8。这两行都基于 Ant 1.9.7,1.9.x 版本主要是错误修复版本,同时为 1.10.x 开发了其他新功能。我们建议使用 1.10.x,除非您需要在构建过程中使用 Java8 之前的 Java 版本。

Ant 1.10.11 包含 1.9.16 的超集 - 除了一些不再适用于 Java8 的任务和特性(如apt任务)。

这两个版本都解决了潜在的拒绝服务漏洞,有关详细信息,请参阅安全报告:https://ant.apache.org/security.html。

从 Ant 1.10.10 到 Ant 1.10.11 的变化

修复了错误:

1、运行时竞争条件可能导致 NullPointerExceptions并行任务。Bugzilla 报告 65316

2、修复了读取损坏档案时潜在的 OutOfMemory 错误使用 tar 或 zip 格式或从 zip 派生的格式。

其他变化:

1、org.apache.tools.ant.taskdefs.optional.junitlauncher.confined.JUnitLauncherTask 现在有一个新的受保护的 createExecuteWatchdog() 方法来允许它被覆盖。Github 拉取请求

2、将 AntUnit 升级到 1.4.1。

从 Ant 1.9.15 到 Ant 1.9.16 的变化

其他变化:

1、将 AntUnit 升级到 1.4.1。

修复了错误:

2、修复了 ant-testutil-sources.jar 发布到 Maven 的错误中央存储库不包含任何源文件。

~阅读全文-人机检测~

关注下方微信公众号“Java精选”(w_z90110),回复关键词领取资料:如Mysql、Hadoop、Dubbo、Spring Boot等,免费领取视频教程、资料文档和项目源码。微信搜索小程序“Java精选面试题”,内涵3000+道Java面试题!

Java精选专注程序员推送一些Java开发知识,包括基础知识、各大流行框架(Mybatis、Spring、Spring Boot等)、大数据技术(Storm、Hadoop、MapReduce、Spark等)、数据库(Mysql、Oracle、NoSQL等)、算法与数据结构、面试专题、面试技巧经验、职业规划以及优质开源项目等。其中一部分由小编总结整理,另一部分来源于网络上优质资源,希望对大家的学习和工作有所帮助。
还可以输入136 讨论区:
评 论